import Foundation
let pattern = ##"^\<\!\-\-\#([a-z]+?)\s([a-z]*\=\".*\")+? \-\-\>$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<!--#include file="test" set="one" two="asdf" -->
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)