$re = '/^\<\!\-\-\#([a-z]+?)\s([a-z]*\=\".*\")+? \-\-\>$/m';
$str = '<!--#include file="test" set="one" two="asdf" -->
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;