re = /^\<\!\-\-\#([a-z]+?)\s([a-z]*\=\".*\")+? \-\-\>$/m
str = '<!--#include file="test" set="one" two="asdf" -->
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result