# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{([A-Z0-9\-_]+)\}/<?php " . $this->compile_var(\1) . " ?>/;t' <<< "<link href=\"{VAR_TEMPLATE_PATH}css/common.css\" rel=\"stylesheet\" type=\"text/css\">
"