re = /\{([A-Z0-9\-_]+)\}/
str = '<link href="{VAR_TEMPLATE_PATH}css/common.css" rel="stylesheet" type="text/css">
'
subst = '<?php " . $this->compile_var(\\1) . " ?>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result