using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{([A-Z0-9\-_]+)\}";
string substitution = @"<?php "" . $this->compile_var(\1) . "" ?>";
string input = @"<link href=""{VAR_TEMPLATE_PATH}css/common.css"" rel=""stylesheet"" type=""text/css"">
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}