use strict;
my $str = '<link href="{VAR_TEMPLATE_PATH}css/common.css" rel="stylesheet" type="text/css">
';
my $regex = qr/\{([A-Z0-9\-_]+)\}/p;
my $subst = '<?php " . $this->compile_var(\\1) . " ?>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";