$re = '/\{([A-Z0-9\-_]+)\}/';
$str = '<link href="{VAR_TEMPLATE_PATH}css/common.css" rel="stylesheet" type="text/css">
';
$subst = "<?php \" . $this->compile_var(\1) . \" ?>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;