package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{([A-Z0-9\-_]+)\}`)
var str = []byte(`<link href="{VAR_TEMPLATE_PATH}css/common.css" rel="stylesheet" type="text/css">
`)
var substitution = []byte("<?php " . $this->compile_var(\1) . " ?>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}