const regex = /\{([A-Z0-9\-_]+)\}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{([A-Z0-9\\-_]+)\\}', '')
const str = `<link href="{VAR_TEMPLATE_PATH}css/common.css" rel="stylesheet" type="text/css">
`;
const subst = `<?php " . $this->compile_var(\1) . " ?>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);