import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{([A-Z0-9\\-_]+)\\}";
final String string = "<link href=\"{VAR_TEMPLATE_PATH}css/common.css\" rel=\"stylesheet\" type=\"text/css\">\n";
final String subst = "<?php \" . $this->compile_var(\\1) . \" ?>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}