import Foundation
let pattern = #"\{([A-Z0-9\-_]+)\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<link href="{VAR_TEMPLATE_PATH}css/common.css" rel="stylesheet" type="text/css">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<?php " . $this->compile_var(\1) . " ?>"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}