# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"y".*\[\s?(\d*)\s?,/\0\1,\1,\1,\1,\1/;t' <<< "\"y\": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]"