# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"y\".*\[\s?(\d*)\s?,"
test_str = "\"y\": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]"
subst = "\\0\\1,\\1,\\1,\\1,\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.