import Foundation
let pattern = #""y".*\[\s?(\d*)\s?,"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""y": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\0\1,\1,\1,\1,\1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}