#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""y".*\[\s?(\d*)\s?,"
Local $sString = ""y": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]"
Local $sSubst = "\0\1,\1,\1,\1,\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)