re = /"y".*\[\s?(\d*)\s?,/
str = '"y": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]'
subst = '\\0\\1,\\1,\\1,\\1,\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result