using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""y"".*\[\s?(\d*)\s?,";
string substitution = @"\0\1,\1,\1,\1,\1";
string input = @"""y"": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}