$re = '/"y".*\[\s?(\d*)\s?,/';
$str = '"y": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]';
$subst = "\0\1,\1,\1,\1,\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;