const regex = /"y".*\[\s?(\d*)\s?,/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"y".*\\[\\s?(\\d*)\\s?,', '')
const str = `"y": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]`;
const subst = `\0\1,\1,\1,\1,\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);