// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""y".*\[\s?(\d*)\s?,"#).unwrap();
let string = "\"y\": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]";
let substitution = "\\0\\1,\\1,\\1,\\1,\\1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}