import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"y\".*\\[\\s?(\\d*)\\s?,";
final String string = "\"y\": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]";
final String subst = "\\0\\1,\\1,\\1,\\1,\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}