# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{/$1} else {/gm;t' <<< " }
else {
Write-Warning
}
else {
Write-Warning"