// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{").unwrap();
let string = " }
else {
Write-Warning
}
else {
Write-Warning";
let substitution = "$1} else {";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}