re = /([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{/m
str = ' }
else {
Write-Warning
}
else {
Write-Warning'
subst = '$1} else {'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result