use strict;
my $str = ' }
else {
Write-Warning
}
else {
Write-Warning';
my $regex = qr/([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{/mp;
my $subst = '$1} else {';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";