#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{"
Local $sString = " }" & @CRLF & _
" else {" & @CRLF & _
" Write-Warning" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" else {" & @CRLF & _
" Write-Warning"
Local $sSubst = "$1} else {"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)