const regex = /([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\S\\r\\n])\\}\\n[^\\S\\r\\n]*else[^\\S\\r\\n]*\\{', 'gm')
const str = ` }
else {
Write-Warning
}
else {
Write-Warning`;
const subst = `$1} else {`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);