import re
regex = re.compile(r"([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{", flags=re.MULTILINE)
test_str = (" }\n"
" else {\n"
" Write-Warning\n\n"
" }\n"
" else {\n"
" Write-Warning")
subst = "$1} else {"
result = regex.sub(subst, test_str)
if result:
print(result)