using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{";
string substitution = @"$1} else {";
string input = @" }
else {
Write-Warning
}
else {
Write-Warning";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}