$re = '/([^\S\r\n])\}\n[^\S\r\n]*else[^\S\r\n]*\{/m';
$str = ' }
else {
Write-Warning
}
else {
Write-Warning';
$subst = "$1} else {";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;