using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+)\b";
string substitution = @"CInt(\1)";
string input = @"Dim A As Integer = 1337
Dim B As Integer = (5 / 2)
Dim C$ = Base64Int(A)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}