re = /\b(\d+)\b/
str = 'Dim A As Integer = 1337
Dim B As Integer = (5 / 2)
Dim C$ = Base64Int(A)'
subst = 'CInt(\\1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result