const regex = /\b(\d+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)\\b', 'g')
const str = `Dim A As Integer = 1337
Dim B As Integer = (5 / 2)
Dim C\$ = Base64Int(A)`;
const subst = `CInt(\1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);