import Foundation
let pattern = #"\b(\d+)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Dim A As Integer = 1337
Dim B As Integer = (5 / 2)
Dim C$ = Base64Int(A)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"CInt(\1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)