use strict;
my $str = 'Dim A As Integer = 1337
Dim B As Integer = (5 / 2)
Dim C$ = Base64Int(A)';
my $regex = qr/\b(\d+)\b/p;
my $subst = 'CInt(\\1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";