using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((http(s)?:\/\/)|(\/))[0-9a-zA-Z_\/\s\ \?\.\:\;\&\=\-\@\%\!\,ùéòàèì\#\|] )?";
string substitution = @"<span class="">\0</span>";
string input = @"/?vw=struttura&id=9";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}