package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(((http(s)?:\/\/)|(\/))[0-9a-zA-Z_\/\s\ \?\.\:\;\&\=\-\@\%\!\,ùéòàèì\#\|] )?`)
var str = `/?vw=struttura&id=9`
var substitution = "<span class="">\0</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}