$re = '/(((http(s)?:\/\/)|(\/))[0-9a-zA-Z_\/\s\ \?\.\:\;\&\=\-\@\%\!\,ùéòàèì\#\|] )?/';
$str = '/?vw=struttura&id=9';
$subst = "<span class=\"\">\0</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;