import re
regex = re.compile(r"(((http(s)?:\/\/)|(\/))[0-9a-zA-Z_\/\s\ \?\.\:\;\&\=\-\@\%\!\,ùéòàèì\#\|] )?")
test_str = "/?vw=struttura&id=9"
subst = "<span class=\"\">\\0</span>"
result = regex.sub(subst, test_str)
if result:
print(result)