re = /(((http(s)?:\/\/)|(\/))[0-9a-zA-Z_\/\s\ \?\.\:\;\&\=\-\@\%\!\,ùéòàèì\#\|] )?/
str = '/?vw=struttura&id=9'
subst = '<span class="">\\0</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result