import Foundation
let pattern = ##"(((http(s)?:\/\/)|(\/))[0-9a-zA-Z_\/\s\ \?\.\:\;\&\=\-\@\%\!\,ùéòàèì\#\|] )?"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/?vw=struttura&id=9"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span class="">\0</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)