use strict;
my $str = '/?vw=struttura&id=9';
my $regex = qr/(((http(s)?:\/\/)|(\/))[0-9a-zA-Z_\/\s\ \?\.\:\;\&\=\-\@\%\!\,ùéòàèì\#\|] )?/p;
my $subst = '<span class="">\\0</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";