import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((http(s)?:\\/\\/)|(\\/))[0-9a-zA-Z_\\/\\s\\ \\?\\.\\:\\;\\&\\=\\-\\@\\%\\!\\,ùéòàèì\\#\\|] )?";
final String string = "/?vw=struttura&id=9";
final String subst = "<span class=\"\">\\0</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}