# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<script[^>]*>[^\0]*?<\\/script>//gi;t' <<< "<!doctype html>
<html>
<head>
<title>Testing</title>
<script src=\"htttp://...\"></script>
</head>
<body>
<img />
<!-- and so on -->
</body>
</html>
<script>
function f(){
if (2 < 5) {
// ...
};
};
</script>"