const regex = /<script[^>]*>[^\0]*?<\/script>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script[^>]*>[^\\0]*?<\\\/script>', 'gi')
const str = `<!doctype html>
<html>
<head>
<title>Testing</title>
<script src="htttp://..."></script>
</head>
<body>
<img />
<!-- and so on -->
</body>
</html>
<script>
function f(){
if (2 < 5) {
// ...
};
};
</script>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);