re = /<script[^>]*>[^\0]*?<\/script>/i
str = '<!doctype html>
<html>
<head>
<title>Testing</title>
<script src="htttp://..."></script>
</head>
<body>
<img />
<!-- and so on -->
</body>
</html>
<script>
function f(){
if (2 < 5) {
// ...
};
};
</script>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result