import Foundation
let pattern = #"<script[^>]*>[^\0]*?<\/script>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<!doctype html>
<html>
<head>
<title>Testing</title>
<script src="htttp://..."></script>
</head>
<body>
<img />
<!-- and so on -->
</body>
</html>
<script>
function f(){
if (2 < 5) {
// ...
};
};
</script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)