$re = '/<script[^>]*>[^\0]*?<\/script>/i';
$str = '<!doctype html>
<html>
<head>
<title>Testing</title>
<script src="htttp://..."></script>
</head>
<body>
<img />
<!-- and so on -->
</body>
</html>
<script>
function f(){
if (2 < 5) {
// ...
};
};
</script>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;