import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<script[^>]*>[^\\0]*?<\\/script>";
final String string = "<!doctype html>\n"
+ "<html>\n"
+ " <head>\n"
+ " <title>Testing</title>\n"
+ " <script src=\"htttp://...\"></script>\n"
+ " </head>\n"
+ " <body>\n"
+ " <img />\n"
+ " <!-- and so on -->\n"
+ " </body>\n"
+ "</html>\n"
+ "<script>\n"
+ " function f(){\n"
+ " if (2 < 5) {\n"
+ " // ...\n"
+ " };\n"
+ " };\n"
+ "</script>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}